Author Topic:  MechCommander Gold - Darkest Hours v3.0 - Bug Reports & Solutions  (Read 4427 times)

25 Oct 17

Reply #90

Offline Gunner

  • Members
  • Rookie
  • *

Another item - not sure if it's a bug or not.

Playing the expansion - just after mission 1 and I am in the Mech Lab trying to configure mechs for the next mission. I have Ilka in a Bushwacker-W with the following loadout:

1 x C small pulse laser - Load Value = 4
4 x C LRM - LV = 3 each, 12 total
2 x C ER medium laser - LV = 3.5 each, 7 total
1 x C LB 10X AC - LV - 13.5

I decided to add: 1 C large pulse laser - LV = 11.

This SHOULD mean that all I need to remove to make room for it, is the 4 C LRMs. Unfortunately, that doesn't work. I finally had to remove 1 C ER medium laser as well. 15.5 LV points removed to fit in one weapon with a LV of 11 - that is some bad mathematics there! And there is no space left to add anything else.

The only thing I can think of is that the AI is somehow seeing different load values than what is shown to us for each weapon.

There are two rules for success:
1.  Never tell everything you know.

25 Oct 17

Reply #91

Offline wherewulf

  • Members
  • Rookie
  • *

Windows 10
Darkest Hours V3.0

I'm having a couple problems. The main one is that I don't know how to exit a mission. In the old MCG, it automatically exited once you had completed all mission objectives. But in Mission 1, Op 1, I'm stuck. I complete the main 3 objectives but it never goes to the "win screen". What do I do to exit?

RizZen added an objective when he redid the game. You have to cross a very long bridge to the west and capture a handful of resources. Just be careful as there is a Timberwolf guarding them. You can try and capture the T-wolf (I can never do it) but just make sure you don't complete at least one of the other objectives before going after the Timberwolf or the mission will finish.

2 Nov 17

Reply #92

Offline tobik_pt

  • Members
  • Rookie
  • *

3 months ago I reported a bug for Op2Mis13 of expansion, I'm still hoping it will be fixed soon :)
Unfortunately I also got stuck now at the original campaign, Op2Mis17. I always try to start the mission with 2 mechs and immediately after the mission completes loading it says "Mission objective can not be completed - Mission failed".
Any ideas why this happens? I tried several combinations of mechs and pilots for the mission, but i can not play it, always mission failed directly at beginning.

Thanks for any help!

6 Nov 17

Reply #93

Offline MoNrOo

  • Members
  • Rookie
  • *

Bug: last mission Original campaign.
After the end of the mission, game crash.

Code: [Select]
EXCEPTION (Access violation at 0x00644964)
Address  : 0x00644964
Location : FullPathFileName::init() +0x24
File     : L:\mcx\Lib\Cident.cpp(50)

Processor/Stack    EAX=0x00000000 EBX=0x0018F2F0 ECX=0xFFFFFFFF EDX=0x0000000E    Flags=0x00210286
===============    ESI=0x0079433C EDI=0x00000011 EBP=0x0018F128 ESP=0x0018F11C    EIP=0x00644964
0x006FC87C Logistics::getCurrentMission() +0x6C G:\mcx\logistics.cpp(10324)
0x0072C0E0 Mission::EndScenario() +0x4C0  L:\mcx\mission\mission.cpp(1515)
0x0072CB8C MissionResultsScreen::destroy() +0x18C L:\mcx\mission\mission.cpp(1827)
0x0072C561 moveOnButtonHandleEvent() +0x21 L:\mcx\mission\mission.cpp(1671)
0x00609EE9 aButton::handleEvent() +0x1A9  L:\mcx\gui\aButton.cpp(254)
0x006116DC handleEvent() +0x72C           G:\mcx\gui\Asystem.cpp(3647)
0x006128EA CheckMouse() +0x10A            G:\mcx\gui\Asystem.cpp(4378)
0x00615846 aCallback::exec() +0x16        G:\mcx\gui\Asystem.cpp(6142)
0x0061455C aSystem::run() +0xCC           G:\mcx\gui\Asystem.cpp(5407)
0x00610EE1 RealWinMain() +0x301           G:\mcx\gui\Asystem.cpp(3081)
0x0075F82A WinMain() +0xCA                L:\mcx\rmain.cpp(74)
0x00762CF2 WinMainCRTStartup() +0xCE     

Machine Details
Executable name           : C:\Giochi\MCG Darkest Hours\MCX1024x768.EXE
Current time, date        : 10:43:05 Tuesday 10/24/2017
Executable time, date     : 08:40:44 Friday 8/25/2006
User name                 :
Machine name              :
Processor                 : GenuineIntel Pentium II MMX
Operating system          :
Version                   :
Time since booted         : 1h 42m 17s
Physical memory           : / bytes  (0 Meg)
Available physical memory : / bytes  (0 Meg)
Swapfile size             : / bytes  (0 Meg)
Swapfile available        : / bytes  (0 Meg)
Virtual memory            : 2,147,352,576 bytes  (2047 Meg)
Available virtual memory  : 1,956,249,600 bytes  (1865 Meg)
Memory load               : 20%

PCI bus

ISA bus

DLL Version numbers
amstream.dll - Version 6.6.7600.16385
quartz.dll - Version 6.6.7600.16385
devenum.dll - Version 6.6.7600.16385
dsound.dll - Version 6.1.7600.16385
dinput.dll - Version 6.1.7600.16385
Could not find 'd3dhalf.dll'
d3dim.dll - Version 6.1.7600.16385
ddraw.dll - Version 6.1.7600.16385
dplayx.dll - Version 6.1.7600.16385
Could not find 'dplay.dll'
ntdll.dll - Version 6.1.7600.16385
rpcrt4.dll - Version 4.00.1073
Ir50_32.dll - Version R.

Information returned by Game

ScenarioTime: 1744.42
ScenarioTurn: 370461
MoverUpdateFreq: 000.00
TurretUpdateFreq: 000.00
WorldStateUpdateFreq: 000.00
WeaponFireUpdateFreq: 000.00
MissionAppName : MechCommander Expansion Release  Version: -- Logistics
DrawingVFXElement : actor1

Mission 2x13 Expansion
After the end of the mission, when i came back on logistic phase, all the mech used in the 2x13 seems without weapons and if i click and try to go to the hangar the game crash, without the option to send a bugs report.

PS: I don't use the "new" mechwarriors, maybe it will help.

Thanks for the works, MC is one of my favourite game.

9 Nov 17

Reply #94

Offline Sublime Turkey

  • Members
  • Rookie
  • *

Also tried to run game on notebook for another test, same Windows 10 x64, but got this: "Error with application run 0xc0000022".
Hi all,

Just downloaded this and am keen to get it running but I'm getting an error similar to the above:

"MCX1920x1080.EXE - Application Error
The application was unable to start correctly (0xc0000022). Click OK to close the application."

ISO is mounted and in a separate directory, compatibility is set to XP SP2 and 8-bit colour. Nothing else running. I've tried the various executables but I get the same error every time.

I've found this error posted elsewhere but no working solutions. Any assistance would be appreciated.


EDIT: Looks like the issue was not having Direct Play enabled. Up and running now.
« Last Edit: 9 Nov 17 by Sublime Turkey »